Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22
  1. #11

    Default Re: back-up wan connection


    ********************
    testing connectivity from cebu (ping lans in manila)


    cebu#ping 192.169.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.169.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/35/40 ms

    cebu#ping 10.0.13.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.13.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms
    cebu#


    everything's fine



    ********************
    testing connectivity from manila (ping lans in cebu)


    manila#ping 192.166.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.166.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/44 ms

    manila#ping 10.0.10.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.10.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/35/44 ms
    manila#


    everything's fine



    ********************
    let's try to bring down the link between cebu and pldt by issuing a shutdown interface at pldt router


    pldt#config t
    pldt(config)#int s0
    pldt(config-if)#shut
    00:55:27: %SYS-5-CONFIG_I: Configured from console by console
    00:55:27: %LINK-5-CHANGED: Interface Serial0, changed state to administratively down
    00:55:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    pldt(config-if)#


    now examine cebu router, it notices the link to pldt is down because it is directly connected to serial0.


    cebu#
    01:17:43: %LINK-3-UPDOWN: Interface Serial0, changed state to down
    01:17:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    cebu#


    cebu's routing table after the link to pldt is down


    cebu#sh ip route

    Gateway of last resort is not set

    C 192.166.12.0/24 is directly connected, Loopback0
    10.0.0.0/24 is subnetted, 1 subnets
    C 10.0.10.0 is directly connected, Loopback1
    cebu#


    notice that it no longer have the static routes! let's try to see the routing table of manila


    manila#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    C 192.168.12.0 is directly connected, Serial0
    C 192.169.12.0/24 is directly connected, Loopback0
    S 192.166.12.0/24 [1/0] via 192.168.12.2
    192.167.12.0/30 is subnetted, 1 subnets
    S 192.167.12.0 [1/0] via 192.168.12.2
    10.0.0.0/24 is subnetted, 2 subnets
    S 10.0.10.0 [1/0] via 192.168.12.2
    C 10.0.13.0 is directly connected, Loopback1
    manila#


    it still has a complete routing table!!! why?!

    static routing does not update remote routers about topology change in contrast to dynamic routing protocols. it would only notice a change when directly connected networks goes down. a workaround here is to manualy configure manila router to take another route for cebu subnets.

    testing network connectivity


    manila#ping 192.166.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.166.12.1, timeout is 2 seconds:
    U.U.U
    Success rate is 0 percent (0/5)
    manila#


    cebu lan is unreachable!!! you should get it working or else you'll get fired! just kidding


  2. #12

    Default Re: back-up wan connection

    your company having mission critical information traversing the wan, your IT manager decided that you need a back-up link incase your pldt link (512kbps) goes down and chose another service provider (globe) for a bandwidth of 128kbps.


    now, your topology looks like this:


    ------- pldt ------
    / \
    cebu manila
    \ /
    ------ globe ------


    **************************
    modified configurations for cebu and manila routers


    cebu#sh run
    !
    hostname cebu
    !
    ip subnet-zero
    !
    interface Loopback0
    ip address 192.166.12.1 255.255.255.0
    !
    interface Loopback1
    ip address 10.0.10.1 255.255.255.0
    !
    interface Serial0
    description this is the way to MANILA via PLDT 512kbps
    ip address 192.167.12.1 255.255.255.252
    !
    interface Serial1
    description this is the way to MANILA via GLOBE 128kbps
    ip address 10.0.11.1 255.255.255.252
    !
    ip classless
    ip route 10.0.12.0 255.255.255.252 10.0.11.2
    ip route 10.0.13.0 255.255.255.0 192.167.12.2
    ip route 10.0.13.0 255.255.255.0 10.0.11.2 50
    ip route 192.168.12.0 255.255.255.252 192.167.12.2
    ip route 192.169.12.0 255.255.255.0 192.167.12.2
    ip route 192.169.12.0 255.255.255.0 10.0.11.2 50
    !
    end


    manila#sh run
    !
    hostname manila
    !
    ip subnet-zero
    !
    interface Loopback0
    ip address 192.169.12.1 255.255.255.0
    !
    interface Loopback1
    ip address 10.0.13.1 255.255.255.0
    !
    interface Serial0
    description this is the way to CEBU via PLDT 256kbps
    ip address 192.168.12.1 255.255.255.252
    !
    interface Serial1
    description this is the way to CEBU via GLOBE 128kbps
    ip address 10.0.12.1 255.255.255.252
    !
    ip classless
    ip route 10.0.10.0 255.255.255.0 192.168.12.2
    ip route 10.0.10.0 255.255.255.0 10.0.12.2 50
    ip route 10.0.11.0 255.255.255.252 10.0.12.2
    ip route 192.166.12.0 255.255.255.0 192.168.12.2
    ip route 192.166.12.0 255.255.255.0 10.0.12.2 50
    ip route 192.167.12.0 255.255.255.252 192.168.12.2
    !
    end


    because we used globe as a back-up link to pldt, we configured floating static routes to the lan networks with an administrative distance of 50 via globe and default AD for static routes for lan networks via pldt.


    **************************
    below are the routing tables of cebu and manila after additional configurations were made


    cebu#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    S 192.168.12.0 [1/0] via 192.167.12.2
    S 192.169.12.0/24 [1/0] via 192.167.12.2
    C 192.166.12.0/24 is directly connected, Loopback0
    192.167.12.0/30 is subnetted, 1 subnets
    C 192.167.12.0 is directly connected, Serial0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C 10.0.10.0/24 is directly connected, Loopback1
    C 10.0.11.0/30 is directly connected, Serial1
    S 10.0.12.0/30 [1/0] via 10.0.11.2
    S 10.0.13.0/24 [1/0] via 192.167.12.2


    notice that 192.169.12.0/24 and 10.0.10.0/24 cebu subnets are still reachable via pldt link because the link via globe has been configured with floating static routes


    manila#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    C 192.168.12.0 is directly connected, Serial0
    C 192.169.12.0/24 is directly connected, Loopback0
    S 192.166.12.0/24 [1/0] via 192.168.12.2
    192.167.12.0/30 is subnetted, 1 subnets
    S 192.167.12.0 [1/0] via 192.168.12.2
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    S 10.0.10.0/24 [1/0] via 192.168.12.2
    S 10.0.11.0/30 [1/0] via 10.0.12.2
    C 10.0.12.0/30 is directly connected, Serial1
    C 10.0.13.0/24 is directly connected, Loopback1


    the same here with manila

  3. #13

    Default Re: back-up wan connection

    ***********************
    testing connectivity using traceroute

    cebu#trace 192.169.12.1

    Type escape sequence to abort.
    Tracing the route to 192.169.12.1

    1 192.167.12.2 12 msec 12 msec 12 msec
    2 192.168.12.1 24 msec * 268 msec

    cebu#trace 10.0.13.1

    Type escape sequence to abort.
    Tracing the route to 10.0.13.1

    1 192.167.12.2 12 msec 12 msec 12 msec
    2 192.168.12.1 20 msec * 20 msec


    everything's fine and packet routes via pldt link


    manila#trace 192.166.12.1

    Type escape sequence to abort.
    Tracing the route to 192.166.12.1

    1 192.168.12.2 12 msec 8 msec 12 msec
    2 192.167.12.1 24 msec * 20 msec

    manila#trace 10.0.10.1

    Type escape sequence to abort.
    Tracing the route to 10.0.10.1

    1 192.168.12.2 12 msec 8 msec 8 msec
    2 192.167.12.1 24 msec * 20 msec


    everything's fine and packet routes via pldt link



    ********************
    again, let's try to bring down the link between cebu and pldt by issuing a shutdown interface at pldt router

    pldt#config t
    pldt(config)#int s0
    pldt(config-if)#shut
    02:45:42: %LINK-5-CHANGED: Interface Serial0, changed state to administratively down
    02:45:43: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    pldt(config-if)#

    again, examine cebu router. it notices the link to pldt is down because it is directly connected to serial0.

    cebu#
    03:07:58: %LINK-3-UPDOWN: Interface Serial0, changed state to down
    03:07:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    cebu#


    cebu's routing table after the link to pldt is down


    cebu#sh ip route

    Gateway of last resort is not set

    S 192.169.12.0/24 [50/0] via 10.0.11.2
    C 192.166.12.0/24 is directly connected, Loopback0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C 10.0.10.0/24 is directly connected, Loopback1
    C 10.0.11.0/30 is directly connected, Serial1
    S 10.0.12.0/30 [1/0] via 10.0.11.2
    S 10.0.13.0/24 [50/0] via 10.0.11.2


    now, manila subnets 192.169.12.0/24 and 10.0.10.0/24 are reachable via the back-up link (globe) which we configured with floating static routes. notice the administrative distance [50/0]. we can conclude that our back-up link is working and this should save our day!!!


    ********************
    testing connectivity from cebu (ping lans in manila)


    cebu#ping 192.169.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.169.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/35/40 ms
    cebu#ping 10.0.13.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.13.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/36 ms


    everything's fine!!!


    testing connectivity from manila (ping lans in cebu)


    manila#ping 192.166.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.166.12.1, timeout is 2 seconds:
    U.U.U
    Success rate is 0 percent (0/5)

    manila#ping 10.0.10.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.10.1, timeout is 2 seconds:
    U.U.U
    Success rate is 0 percent (0/5)


    what the...?!!! how can cebu subnetworks be unreachable?!!!

  4. #14

    Default Re: back-up wan connection

    an examination of manila's routing table reveals the problem


    manila#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    C 192.168.12.0 is directly connected, Serial0
    C 192.169.12.0/24 is directly connected, Loopback0
    S 192.166.12.0/24 [1/0] via 192.168.12.2
    192.167.12.0/30 is subnetted, 1 subnets
    S 192.167.12.0 [1/0] via 192.168.12.2
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    S 10.0.10.0/24 [1/0] via 192.168.12.2
    S 10.0.11.0/30 [1/0] via 10.0.12.2
    C 10.0.12.0/30 is directly connected, Serial1
    C 10.0.13.0/24 is directly connected, Loopback1


    it still routes through the pldt link! notice the next-hop address? what's happening?

    even though we configured floating static routes as a back-up link incase pldt link goes down, manila router did not notice the topology change from cebu because it is not directly connected. static routing does not offer routing updates. in this situation, you should manualy shut down the manila pldt link (serial interface) in order to route packets to cebu subnetworks.

    manila#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    manila(config)#int s0
    manila(config-if)#shut
    manila(config-if)#^Z
    03:03:58: %SYS-5-CONFIG_I: Configured from console by console
    03:03:59: %LINK-5-CHANGED: Interface Serial0, changed state to administratively down
    03:04:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

    manila#sh ip route

    Gateway of last resort is not set

    C 192.169.12.0/24 is directly connected, Loopback0
    S 192.166.12.0/24 [50/0] via 10.0.12.2
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    S 10.0.10.0/24 [50/0] via 10.0.12.2
    S 10.0.11.0/30 [1/0] via 10.0.12.2
    C 10.0.12.0/30 is directly connected, Serial1
    C 10.0.13.0/24 is directly connected, Loopback1


    now the back-up links come-up...

    testing connectivity


    manila#ping 192.166.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.166.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/48 ms

    manila#ping 10.0.10.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.10.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms
    manila#

    networks are rechable, and everyone's happy!


    the best way to avoid this problem is to configure a dynamic routing protocol. it releases your burden of manualy configuring another route when a topology changes. RIPv2 is probably the simplest dynamic routing protocol that can be configured.

    note: when you migrate from static routing to a dynamic routing protocol, just leave first the static routes as-is then configure all routers with rip. check the rip database then slowly removing the static routes one-by-one then check to see if a route exists in the routing table. as a precaution, you should always back-up your existing configurations incase your new configuration doesn't work. you may also test your new configuration on quiter hours when it is not critical to change configurations on the router. start at the remote sites and towards your router in that way you would not loose connectivity while in telnet.

    RIPv2 allows subnet maks to be included in routing updates along with the next-hop address. thus allowing you to implement vlsma and classless routing. RIPv1 is a classful routing protocol and should be avoided when necessary.


    example configurations of RIPv2

    cebu#config t
    cebu(config)#router rip
    cebu(config-router)#network 192.166.12.0
    cebu(config-router)#network 192.167.12.0
    cebu(config-router)#network 10.0.0.0
    cebu(config-router)#passive-interface loopback 0
    cebu(config-router)#passive-interface loopback 1
    cebu(config-router)#version 2
    cebu(config-router)#no auto-summary
    cebu(config-router)#^Z
    cebu#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    S 192.168.12.0 [1/0] via 192.167.12.2
    S 192.169.12.0/24 [1/0] via 192.167.12.2
    C 192.166.12.0/24 is directly connected, Loopback0
    192.167.12.0/30 is subnetted, 1 subnets
    C 192.167.12.0 is directly connected, Serial0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C 10.0.10.0/24 is directly connected, Loopback1
    C 10.0.11.0/30 is directly connected, Serial1
    S 10.0.12.0/30 [1/0] via 10.0.11.2
    S 10.0.13.0/24 [1/0] via 192.167.12.2


    cebu's routing table still displays the static routes, remember that static routes have an administrative distance of 1 and our floating static routes have an administrative distance of 50 but RIP has an AD of 120. rip routes would not be put into the routing table unless we remove the static routes.


    cebu#config t
    cebu(config)#no ip route 10.0.12.0 255.255.255.252 10.0.11.2
    cebu(config)#no ip route 10.0.13.0 255.255.255.0 192.167.12.2
    cebu(config)#no ip route 10.0.13.0 255.255.255.0 10.0.11.2 50
    cebu(config)#no ip route 192.168.12.0 255.255.255.252 192.167.12.2
    cebu(config)#no ip route 192.169.12.0 255.255.255.0 192.167.12.2
    cebu(config)#no ip route 192.169.12.0 255.255.255.0 10.0.11.2 50
    cebu(config)#^Z
    cebu#sh ip route

    Gateway of last resort is not set

    192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
    R 192.168.12.0/30 [120/1] via 192.167.12.2, 00:00:07, Serial0
    R 192.168.12.0/24 is possibly down,
    routing via 192.167.12.2, Serial0
    R 192.169.12.0/24 [120/2] via 192.167.12.2, 00:00:00, Serial0
    [120/2] via 10.0.11.2, 00:00:00, Serial1
    C 192.166.12.0/24 is directly connected, Loopback0
    192.167.12.0/30 is subnetted, 1 subnets
    C 192.167.12.0 is directly connected, Serial0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C 10.0.10.0/24 is directly connected, Loopback1
    C 10.0.11.0/30 is directly connected, Serial1
    R 10.0.12.0/30 [120/1] via 10.0.11.2, 00:00:25, Serial1
    R 10.0.13.0/24 [120/2] via 192.167.12.2, 00:00:00, Serial0
    [120/2] via 10.0.11.2, 00:00:00, Serial1


    manila's configuration


    manila#config t
    manila(config)#router rip
    manila(config-router)#net 192.169.12.0
    manila(config-router)#net 192.168.12.0
    manila(config-router)#net 10.0.0.0
    manila(config-router)#passive-interface loopback 0
    manila(config-router)#passive-interface loopback 1
    manila(config-router)#version 2
    manila(config-router)#no auto
    manila(config-router)#exit
    manila(config)#no ip route 10.0.10.0 255.255.255.0 192.168.12.2
    manila(config)#no ip route 10.0.10.0 255.255.255.0 10.0.12.2 50
    manila(config)#no ip route 10.0.11.0 255.255.255.252 10.0.12.2
    manila(config)#no ip route 192.166.12.0 255.255.255.0 192.168.12.2
    manila(config)#no ip route 192.166.12.0 255.255.255.0 10.0.12.2 50
    manila(config)#no ip route 192.167.12.0 255.255.255.252 192.168.12.2
    manila(config)#^z
    manila#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    C 192.168.12.0 is directly connected, Serial0
    C 192.169.12.0/24 is directly connected, Loopback0
    R 192.166.12.0/24 [120/2] via 10.0.12.2, 00:00:04, Serial1
    [120/2] via 192.168.12.2, 00:00:12, Serial0
    192.167.12.0/30 is subnetted, 1 subnets
    R 192.167.12.0 [120/1] via 192.168.12.2, 00:00:12, Serial0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    R 10.0.10.0/24 [120/2] via 10.0.12.2, 00:00:04, Serial1
    [120/2] via 192.168.12.2, 00:00:13, Serial0
    R 10.0.11.0/30 [120/1] via 10.0.12.2, 00:00:05, Serial1
    C 10.0.12.0/30 is directly connected, Serial1
    C 10.0.13.0/24 is directly connected, Loopback1


    notice that you now have two routes for the 192.166.12.0/24 and 10.0.10.0/24 cebu subnetworks via 10.0.12.2 and 192.168.12.2? load balancing your links would be much more cost-effective rather making the other link as a back-up. if you want certain networks to route a certain path, you can create static routes for that specific network or use policy-based routing with route-maps. if there are some networks you don't want to be advertised or which might create a routing-loop, you can filter routing updates with distribute-lists by specifying networks thru access-lists.

  5. #15

    Default Re: back-up wan connection

    ***********************
    finally, let's try to bring down the link between cebu and pldt for the last time by issuing a shutdown interface at pldt router


    pldt#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    pldt(config)#int s0
    pldt(config-if)#shut
    03:40:18: %LINK-5-CHANGED: Interface Serial0, changed state to administratively down
    03:40:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    pldt(config-if)#


    on cebu and manila routers, debugging has been turned on to examine topology changes and routing updates


    cebu#debug ip routing
    IP routing debugging is on
    cebu#
    04:02:34: %LINK-3-UPDOWN: Interface Serial0, changed state to down
    cebu#
    04:02:34: is_up: 0 state: 0 sub state: 1 line: 0
    04:02:34: RT: del 10.0.13.0/24 via 192.167.12.2, rip metric [120/2]
    04:02:34: RT: del 192.168.12.0/30 via 192.167.12.2, rip metric [120/1]
    04:02:34: RT: delete subnet route to 192.168.12.0/30
    04:02:34: RT: delete network route to 192.168.12.0
    04:02:34: RT: del 192.169.12.0 via 192.167.12.2, rip metric [120/2]
    04:02:34: RT: interface Serial0 removed from routing table
    04:02:34: RT: del 192.167.12.0/30 via 0.0.0.0, connected metric [0/0]
    04:02:34: RT: delete subnet route to 192.167.12.0/30
    04:02:34: RT: delete network route to 192.167.12.0
    04:02:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    cebu#
    04:02:35: is_up: 0 state: 0 sub state: 1 line: 0
    04:02:36: RT: add 192.168.12.0/30 via 10.0.11.2, rip metric [120/2]
    cebu#un all
    All possible debugging has been turned off
    cebu#


    notice the deletion of network routes for the pldt links


    manila#debug ip routing
    IP routing debugging is on
    manila#
    03:38:26: RT: del 10.0.10.0/24 via 192.168.12.2, rip metric [120/2]
    03:38:26: RT: del 192.166.12.0 via 192.168.12.2, rip metric [120/2]
    03:38:26: RT: del 192.167.12.0/30 via 192.168.12.2, rip metric [120/1]
    03:38:26: RT: delete subnet route to 192.167.12.0/30
    03:38:26: RT: delete network route to 192.167.12.0
    manila#un all
    All possible debugging has been turned off
    manila#


    now unlike in static routing, manila router has been informed with the change in topology and has acted accordingly.


    checking the routing tables for cebu and manila routers


    cebu#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    R 192.168.12.0 [120/2] via 10.0.11.2, 00:00:04, Serial1
    R 192.169.12.0/24 [120/2] via 10.0.11.2, 00:00:04, Serial1
    C 192.166.12.0/24 is directly connected, Loopback0
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback1000
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C 10.0.10.0/24 is directly connected, Loopback1
    C 10.0.11.0/30 is directly connected, Serial1
    R 10.0.12.0/30 [120/1] via 10.0.11.2, 00:00:04, Serial1
    R 10.0.13.0/24 [120/2] via 10.0.11.2, 00:00:04, Serial1
    131.108.0.0/24 is subnetted, 1 subnets
    C 131.108.1.0 is directly connected, Ethernet0


    manila#sh ip route

    Gateway of last resort is not set

    192.168.12.0/30 is subnetted, 1 subnets
    C 192.168.12.0 is directly connected, Serial0
    C 192.169.12.0/24 is directly connected, Loopback0
    R 192.166.12.0/24 [120/2] via 10.0.12.2, 00:00:01, Serial1
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    R 10.0.10.0/24 [120/2] via 10.0.12.2, 00:00:01, Serial1
    R 10.0.11.0/30 [120/1] via 10.0.12.2, 00:00:01, Serial1
    C 10.0.12.0/30 is directly connected, Serial1
    C 10.0.13.0/24 is directly connected, Loopback1


    now, both cebu and manila routers are using the globe back-up link and networks are reachable

    tesing connectivity



    cebu#ping 192.169.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.169.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/40 ms

    cebu#ping 10.0.13.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.13.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/36 ms

    cebu#trace 192.169.12.1

    Type escape sequence to abort.
    Tracing the route to 192.169.12.1

    1 10.0.11.2 8 msec 12 msec 12 msec
    2 10.0.12.1 20 msec * 20 msec

    cebu#trace 10.0.13.1

    Type escape sequence to abort.
    Tracing the route to 10.0.13.1

    1 10.0.11.2 12 msec 8 msec 8 msec
    2 10.0.12.1 16 msec * 20 msec


    manila#ping 192.166.12.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.166.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/44 ms

    manila#ping 10.0.10.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.10.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/37/44 ms

    manila#trace 192.166.12.1

    Type escape sequence to abort.
    Tracing the route to 192.166.12.1

    1 10.0.12.2 12 msec 12 msec 12 msec
    2 10.0.11.1 20 msec * 16 msec

    manila#trace 10.0.10.1

    Type escape sequence to abort.
    Tracing the route to 10.0.10.1

    1 10.0.12.2 12 msec 12 msec 12 msec
    2 10.0.11.1 20 msec * 20 msec



    final router configurations


    cebu#sh run
    Building configuration...

    Current configuration : 1540 bytes
    !
    version 12.2
    !
    hostname cebu
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Loopback0
    ip address 192.166.12.1 255.255.255.0
    !
    interface Loopback1
    ip address 10.0.10.1 255.255.255.0
    !
    interface Serial0
    description this is the way to MANILA via PLDT 512kbps
    ip address 192.167.12.1 255.255.255.252
    !
    interface Serial1
    description this is the way to MANILA via GLOBE 128kbps
    ip address 10.0.11.1 255.255.255.252
    !
    router rip
    version 2
    passive-interface Loopback0
    passive-interface Loopback1
    network 10.0.0.0
    network 192.166.12.0
    network 192.167.12.0
    no auto-summary
    !
    ip classless
    !
    end




    manila#sh run
    Building configuration...

    Current configuration : 1097 bytes
    !
    version 12.2
    !
    hostname manila
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Loopback0
    ip address 192.169.12.1 255.255.255.0
    !
    interface Loopback1
    ip address 10.0.13.1 255.255.255.0
    !
    interface Serial0
    description this is the way to CEBU via PLDT 256kbps
    ip address 192.168.12.1 255.255.255.252
    !
    interface Serial1
    description this is the way to CEBU via GLOBE 128kbps
    ip address 10.0.12.1 255.255.255.252
    !
    router rip
    version 2
    passive-interface Loopback0
    passive-interface Loopback1
    network 10.0.0.0
    network 192.168.12.0
    network 192.169.12.0
    no auto-summary
    !
    ip classless
    !
    end


    ***********************

    for comments or suggestions, please contact me at ridneylaudiano@yahoo.com


  6. #16

    Default Re: back-up wan connection

    edsel,

    i forgot to test static routing with recursive lookup's but i think it would still fail though.

    let me know if you solved your problems.

  7. #17

    Default Re: back-up wan connection

    Quote Originally Posted by mr.twin
    we had a wan connection using globe line and pldt . Im using static routing protocol my globe line wan connection I make it a back-up so I put an administrative distance 50 so the prioritise the pldt connection when the pldt lan goes down then globeline will not auto matically up...
    what could be the sulution...
    @Mr. Twin, I guess your using default route, right? (mostly a configuration of an internet)... I think for me, its very difficult to configure a load balancing or fail-over in 2 different WAN not unless if your networks setup is point-to-point(just what ridney post it). By this setup, you can determine the network connectivity because it's only adjacent. But in your setup, your packet will traverse via hop/router by another hop and then, it will arrive to the destination (your branch office), let say, what if there is a link down 2 hops away from your router? your router will not notice that coz since your only using default route(static). You're only injecting a default route of your router and the adjacent router(pldt/globe router) will be the one to redistribute your routing proto. As of what i understand, The Internet Service provider uses BGP routing on their boundary side...

    I suggest to contact your pldt/globe ISP regarding your set-up. Try also asking them if it's possible to use bgp as your routing protocol. Or else, you have to configure manually your router... BY d way, you're using cisco router or another router?

  8. #18

    Default Re: back-up wan connection

    rid ,

    thanks you very much for the help .. actaully I try to implement that idea but I ask first the permission from our bosing.. If I change my routing protocol from manila and cebu ill also change the other branches....

    daghan salamat rid..you read all routing gyod...


    juan t.

    im using cisco router

  9. #19

    Default Re: back-up wan connection

    Mr. Twin, sorry i thought your network set-up is via internet. IP VPN(MPLS) diay! hehe. RIP is the easiest way to implement. But problem occur when you got a large network. RIP used to implement only in a small to medium size network. The RIP metric uses hop so its very easy to determine if how many hops(router) before it will arrive to the destination. There are many ways to implement your network... you can have eigrp(for pldt) and mixed with static(for globe by lowering AD), or OSPF.

    Quote Originally Posted by mr.twin
    we had a wan connection using globe line and pldt . Im using static routing protocol my globe line wan connection I make it a back-up so I put an administrative distance 50 so the prioritise the pldt connection when the pldt lan goes down then globeline will not auto matically up...
    what could be the sulution...
    Possibly, the fail-over routing won't work because floating static uses typically on what did RIdney post it. But in the real infrastracture, your edge routers (cebu) is directly connected with the pldt routers and pldt routers is not directly connected to your edge routers(mnla). it is travel by hop to another hop. My point is static route will depend only in the adjacent router (directly connected) if adjacent router goes down route will switch over to the floating static (another route) which is your globe. Now, what if router is down with in the pldt autonomous? That's the problem now since your edge router thought that there is still route on the pldt side because of the static route. When u issue "sh ip route" you still see in the routing tabel that you have a route on that network...

    For static routing in IP VPN, your routing will be default static and telco will be the one to route from other PVC (DLCI).

  10. #20

    Default Re: back-up wan connection

    yes sir,

    i try to change the routing protocol from static to ripv2 just ridney advice..but it needs more time cause if I change and ask permission for my bosing...

    thnks a lot sa advice

  11.    Advertisement

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

 
  1. help me plss..i need back up
    By jouho in forum Software & Games (Old)
    Replies: 0
    Last Post: 04-26-2007, 03:46 PM
  2. Windows 2003 Server (File Back-up)
    By jdimpas in forum Networking & Internet
    Replies: 0
    Last Post: 08-18-2006, 01:02 PM
  3. Backing up PS2 saves on a flash drive
    By argon1199 in forum Software & Games (Old)
    Replies: 3
    Last Post: 07-20-2006, 11:28 PM
  4. Booster sa dial-up internet connection
    By SpongeBob2pants in forum Networking & Internet
    Replies: 8
    Last Post: 07-19-2006, 12:49 PM
  5. Replies: 7
    Last Post: 07-05-2006, 05:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
about us
We are the first Cebu Online Media.

iSTORYA.NET is Cebu's Biggest, Southern Philippines' Most Active, and the Philippines' Strongest Online Community!
follow us
#top